While installing setup I am getting this error , I am working under proxy server , Please help me


#1

Picked up _JAVA_OPTIONS: -Djava.net.preferIPv4Stack=true
Warning: java.net.ConnectException: Connection timed out: connect
Warning: Failed to download any source lists!
Warning: File C:\Users\pjpandey.android\repositories.cfg could not be loaded.
Warning: Failed to find package platform-tools


The “android” command is deprecated.
For manual SDK, AVD, and project management, please use Android Studio.
For command-line tools, use tools\bin\sdkmanager.bat
and tools\bin\avdmanager.bat


“android” SDK commands can be translated to sdkmanager commands on a best-effort basis.
(This prompt can be suppressed with the --use-sdk-wrapper commend-line argument
or by setting the USE_SDK_WRAPPER environment variable)
Continue? [y/N]: Invoking “C:\Users\pjpandey\AppData\Local\Android\sdk\tools\bin\sdkmanager” tools --include_obsolete

Picked up _JAVA_OPTIONS: -Djava.net.preferIPv4Stack=true
Warning: java.net.ConnectException: Connection timed out: connect
Warning: Failed to download any source lists!
Warning: File C:\Users\pjpandey.android\repositories.cfg could not be loaded.
Warning: Failed to find package tools


The “android” command is deprecated.
For manual SDK, AVD, and project management, please use Android Studio.
For command-line tools, use tools\bin\sdkmanager.bat
and tools\bin\avdmanager.bat



#2

Did you get the error while installing throught npm commands?

Read on how to set up npm proxy.
https://www.npmjs.com/package/nativescript#configure-proxy-usage


#3

Thanks for your comment. I really aprreciate your time. I had npm proxy set. Problem was with gradle proxy. I did by writting proxy in gradle.properties