VSCode becomes very slow when I work on a NativeScript Project



Hi everyone,
Visual Studio Code becomes very slow when I work on a NativeScript project.
but works well on a simple Angular Project !!!
anyone experiencing this kind of issue ?
I’m using tns 3.3.1


I have this bug when running for iOS as it SASS keeps disconnecting and when I restart the debugger it start a new SASS compiler without killing existing process after awhile it takes over the ram and becomes slow, so I had to kill princess manually or restart my mac.

here is my original topic https://discourse.nativescript.org/t/vs-code-nsposixerrordomain-mac/3111


And no solution for this yet ?!!
anyway I switched to WebStorm and it works perfectly fine now with live sync.


The issue is pretty isolated to NativeScript Angular projects. Regular PAN apps work perfectly in VSCode. I suggest the following settings to optimize your experience in VSCode (or others that come across this thread).

    "files.watcherExclude": {
        "platforms/**": true,
        "node_modules/**": true,
    "search.exclude": {
        "platforms": true,
        "node_modules": true,

You will want to configure the paths to match your project’s setup. Ideally you don’t need VSCode to traverse and index anything in platforms. The livesyncing causes VSCode to exhaust a lot of resources to figure out all the files in your project’s folder.


@sean-perkins Thanks for your response but where should I put those lines ? (I’m newbie :p)


VSCode offers two different setting options. Global user settings (Code > Preferences > Settings) or project-level/workspace settings.

You can create those by creating a .vscode folder in the root of your project and creating a settings.json file inside of it with the supplied code above.


Thanks for your help :slight_smile: