Updating nativescript/xcodebuild errors


#1

I am attempting to update my tns using the commands found on the installation site: “npm install -g nativescript” and it appears to run fine but then when I run tns info I get the table showing that I’m still not running the latest. When I try to run the Ruby setup script for macOS I get the following error: NativeScript requires Xcode. If you do not have Xcode installed, download and install it from App Store and run it once to complete its setup. Do you have Xcode installed? (y/n) y xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance Xcode is not installed or not configured properly. Download, install, set it up and run this script again.

I have XCode 9.1 installed and confirmed it can build a test project, and iOS simulator works. tns info now reports that I’m running 3.4.1 and that 3.4.2 is the latest, and now it’s reporting that tns-core-modules and tns-android tns-ios are all NOT installed. Is there a best way to purge all of the installations because even after running uninstall with npm it still appears the tns command will still run. I’m not sure what is going on here but I have had NativeScript running flawlessly previously…


#2

Looks like you have installed x code but not development tools
Try this: sudo xcode-select --reset
And then run tns doctor