Unable to use nativescript cli


#1

Hello, I’m trying to install nativescript. I have already tried to reinstall it like 10x, but it still doesn’t work. First of all, this is my setup:

  • node: v6.11.0
  • npm: v4.5.0
  • windows 10
  • tns: v3.0.3
  • tns doctor: No issues were detected.
  • android sdk manager: installed build tools (25.0.2, 26), tools (25.2.5), platform tools (26), api 25 sdk platform, google api intel 25 and so on… I also have virtual device.
  • ANDROID_HOME and JAVA_HOME variables have correct values

So everything seems to be fine… Unless I try to use any tns command. E.g.

tns create test --ng
-- tns-template-hello-world-ng@3.0.0


The plugin tns-template-hello-world-ng@3.0.0 is already installed
TypeError: Path must be a string. Received undefined
# create

┌───────────────┬────────────────────────────────────────────────────────────┐
│ Usage         │ Synopsis                                                   │
│ Create from   │ $ tns create <App Name> [--path <Directory>] [--appid <App │
│ default       │ ID>]
..

It just does nothing. I don’t have any new folder test. I’m always getting this error “TypeError: Path must be a string. Received undefined” What’s wrong? If you would like to see --log trace option, it is available here.

I also tried to run official example app. I downloaded source code, installed required npm packages and running “tns run android” but I’m getting same error…

Thanks for any help.

Edit: looks like many users are having same problem…


#2

I have the same problem, Did you solved it?


#3

Just partly, I had to edit npm-installation-manager.js, it looks like there’s something wrong with project path in my case. However, I submitted a new issue on github so I hope somebody is going to take a look at it.