Unable to upgrade to 3.1.3 on Windows 10


#1

I run Nativescript 3.1.2 OK, but am unable to go past that. Here’s what happens:


PS F:…> npm install -g nativescript
npm WARN deprecated node-uuid@1.4.7: Use uuid module instead

  • deep-equal@1.0.1 node_modules\nativescript\node_modules\deep-equal
  • json-merge-patch@0.2.3 node_modules\nativescript\node_modules\json-merge-patch
  • base64-js@0.0.8 node_modules\nativescript\node_modules\plist-merge-patch\node_modules\base64-js
  • xmlbuilder@4.0.0 node_modules\nativescript\node_modules\plist-merge-patch\node_modules\xmlbuilder
  • assert-plus@1.0.0 node_modules\nativescript\node_modules\verror\node_modules\assert-plus
    C:\Users\kmand_000\AppData\Roaming\npm
    `-- (empty)

npm ERR! Windows_NT 10.0.14393
npm ERR! argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “-g” "nativescript"
npm ERR! node v6.8.1
npm ERR! npm v3.10.8
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported platform for fsevents@1.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm ERR! notsup Valid OS: darwin
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: win32
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:
npm ERR! F:…\npm-debug.log
npm ERR! code 1
PS F:…>


I could post the debug log, if that makes sense. This is not holding anything up for me, but I love upgrades as much as anyone else!


#2

Hey @nmandyam npm 3.10.8 is known to have a lot of bugs. Could you update to npm 3.10.10 or 4 something, clean the npm cache npm cache clean and try installing nativescript again?


#3

npm was on 5.4.0, but regardless, I “upgraded” that and cleaned cache, NativeScript upgrade worked ok, thanks!
There still were errors along the way, log shown below - don’t know if that’ll affect behaviour going forward. Will post here if something breaks.
Thanks again!


nativescript@3.1.2 preuninstall C:\Users\kmand_000\AppData\Roaming\npm\node_mo
dules\nativescript
node preuninstall.js

Support for Node.js 8.4.0 is not verified. This CLI might not install or run pro
perly.

C:\Users\kmand_000\AppData\Roaming\npm\tns -> C:\Users\kmand_000\AppData\Roaming
\npm\node_modules\nativescript\bin\tns
C:\Users\kmand_000\AppData\Roaming\npm\nativescript -> C:\Users\kmand_000\AppDat
a\Roaming\npm\node_modules\nativescript\bin\tns

nativescript@3.1.3 postinstall C:\Users\kmand_000\AppData\Roaming\npm\node_mod
ules\nativescript
node postinstall.js

NOTE: You can develop for iOS only on Mac OS X systems.
To be able to work with iOS devices and projects, you need Mac OS X Mavericks or
later.

Your components are up-to-date.

If you are using bash or zsh, you can enable command-line completion.
? Do you want to enable it now? No

Installation successful. You are good to go. Connect with us on http://twitter.c
om/NativeScript.

npm ERR! path C:\Users\kmand_000\AppData\Roaming\npm\node_modules\nativescript\n
ode_modules\nan\package.json
npm ERR! code EPERM
npm ERR! errno -4048
npm ERR! syscall unlink
npm ERR! Error: EPERM: operation not permitted, unlink 'C:\Users\kmand_000\AppDa
ta\Roaming\npm\node_modules\nativescript\node_modules\nan\package.json’
npm ERR! { Error: EPERM: operation not permitted, unlink 'C:\Users\kmand_000\Ap
pData\Roaming\npm\node_modules\nativescript\node_modules\nan\package.json’
npm ERR! stack: ‘Error: EPERM: operation not permitted, unlink ‘C:\Users\km
and_000\AppData\Roaming\npm\node_modules\nativescript\node_modules\nan\p
ackage.json’’,
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! syscall: ‘unlink’,
npm ERR! path: ‘C:\Users\kmand_000\AppData\Roaming\npm\node_modules\nat
ivescript\node_modules\nan\package.json’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\kmand_000\AppData\Roaming\npm-cache_logs\2017-09-03T01_43
_23_169Z-debug.log