Unable to run NS+Angular app in my iOS device

nativescriptcore

#1

I have already asked this question in StackOverflow
Can anyone help me on this? I am trying to run my NativeScript + Angular app in my iPhone.

Terminal Creation

Created tns create mysample --ng app, added iOS platform, successfully built with warnings and run time error arising when I tried to run in Xcode.

Playground Creation

Downloaded NativeScript + Angular app from NativeScriptPlayground, added iOS platform, successfully built with warnings and run time error arising when I tried to run in Xcode.

Issue:

In both cases, app is successfully installed in my device but when launch screen is launched, then immediately app is getting crashed.

Run time Error:


#2

Run time exceptions may depend on what you have in your code. Would you mind sharing the playground example you mentioned?


#3

I don’t add anything in Code. Just, create angular project , add platform iOS , build iOS, and open Xcode.project and run in my device. @manojdcoder


#4

May I know why you are trying to install app via Xcode rather just use CLI commands?

Also, May I know your CLI and Xcode version?
Which commands you use to compile iOS app after creating / downloading your project from Playground?


#5

I am iOS Native developer. So, Xcode, is familiar to me. But, via terminal also, I tried to run, tns run ios , at that time also I am receiving same error.

Version:

Xcode 9.2
28%20PM

NS + JS

tns create HelloWorld --template nativescript-template-tutorial , using this command, I can able to create project , then, tns run ios , app is launching in device and working fine.

NS + Angular

tns create HelloWorld --template nativescript-template-ng-tutorial , using this command, I can able to create project, then, tns run ios , app is launching in device, but above error occurred.

Issue in Angular build

I don’t know, why this Hook skipped issue rising?

Kindly help me on this @manojdcoder . I can’t move further. :disappointed_relieved:


#6

This seems something specific to your local config. Did you try running non-angular apps, is the result same?


#7

Non - Angular apps are working fine. Means, NS + JS.