Unable to create project (3.2.1)


#1

Trying to do the tutorial for NativeScript (Installed it today)
everything is up to date

Node is on 8.1.2
NPM is on 5.4.2
NativeScript is on 3.2.1

If I run command prompt without admin I get
Command npm.cmd install nativescript-template-tutorial@3.1.0 --silent --save-exact --save failed with exit code 4294963248

If I run it with admin I get
cp: no such file or directory: C:\Test\HelloWorld\node_modules\nativescript-template-tutorial\*

I also get
c:\Windows\System32\node_modules\iconv>if not defined npm_config_node_gyp (node "C:\Users\Christopher\AppData\Roaming\npm\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild )

c:\Windows\System32\node_modules\node-icu-charset-detector>if not defined npm_config_node_gyp (node "C:\Users\Christopher\AppData\Roaming\npm\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild )

Tried using Sidekick and the same issues just happen, What am I doing wrong?
doing tns doctor tells me there are no issues


#2

Looks like errors with node and npm. Could you try reinstalling them both?


#3

Alright I’ll give it a go and report back in a few minutes


#4

Still the same problem except now running without admin produces exit code 1 instead of 4294963248


#5

Looks like you’re running non supported version of node/npm - why not install the LTS support version 6.11.3


#6

Do downgrade node to that version then? I’ll give it a go soon and let you know the results


#7

Downgraded node to 6.11.3 using nvm and still getting the same errors as before, I’m not sure what else I should try or are doing wrong? (assuming NPM is also mean’t to be downgraded with it because nvm does that automatically)