Unable to build app with firebase plugin

nativescriptcore

#1

i tried to create firebse template with sidekick and all i got is this.

[18-08-09 11:44:41.830] Command npm.cmd install failed with exit code 1 Error output: 
 npm WARN deprecated bfj-node4@5.3.1: Switch to the `bfj` package for fixes and new features!
npm WARN deprecated babel-preset-es2015@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update! 
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\package.json'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\README.md'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\LICENSE'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\js\function.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\js\regexp.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\js\undefined.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\map.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\merge.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\null.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\omap.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\pairs.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\seq.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\set.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\str.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\js-yaml-da125d3c\lib\js-yaml\type\timestamp.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\ignore-walk\index.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\ignore-walk\LICENSE'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\ignore-walk\package.json'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\ignore-walk\README.md'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\node-pre-gyp\lib\util\abi_crosswalk.json'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\node-pre-gyp\lib\util\compile.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\node-pre-gyp\lib\util\handle_gyp_opts.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf\node_modules\node-pre-gyp\lib\util\napi.js'
npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN extract-text-webpack-plugin@3.0.2 requires a peer of webpack@^3.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN awesome-typescript-loader@5.0.0 requires a peer of typescript@^2.7 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN enoent SKIPPING OPTIONAL DEPENDENCY: ENOENT: Cannot cd into 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\fsevents-acb8a1bf'
npm ERR! code EINTEGRITY
npm ERR! sha512-McHPg0n1pIke+A/4VcaS2en+pTNjy4xF+Uuq86u/5dyDO59/TtFZtQ708QIRkEZ3qwKz3GVkVa6mpxK/CpB8Rg== integrity checksum failed when using sha512: wanted sha512-McHPg0n1pIke+A/4VcaS2en+pTNjy4xF+Uuq86u/5dyDO59/TtFZtQ708QIRkEZ3qwKz3GVkVa6mpxK/CpB8Rg== but got sha512-Sq+GoZ2o8FagB6uE9UYY049gr91NW1c4MhzTJAVjWW/vQHbpjSa7tgtV9EyWjet+7OnlNSEr1pUGe7dOz4J2dg==. (26750 bytes)
npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\admin\AppData\Roaming\npm-cache\_logs\2018-08-09T06_12_11_868Z-debug.log
, Error: Command npm.cmd install failed with exit code 1 Error output: 
 npm WARN deprecated bfj-node4@5.3.1: Switch to the `bfj` package for fixes and new features!
npm WARN deprecated babel-preset-es2015@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update! 
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\package.json'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\README.md'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\fbtemp\node_modules\.staging\global-modules-path-1c5cdf4c\LICENSE'

next in command line. i refered eddy blog

i carefully went through this and didnt missed any steps he mentioned, and all i got even after deleting node modules and platforms is this

Gradle build...
         + setting applicationId
         + applying user-defined configuration from C:\Users\admin\Desktop\workspace\firebaseInit\app\App_Resources\Android\app.gradle
         + adding nativescript runtime package dependency: nativescript-optimized-with-inspector
         + adding aar plugin dependency: C:\Users\admin\Desktop\workspace\firebaseInit\node_modules\nativescript-plugin-firebase\platforms\android\firebase-release.aar
         + adding aar plugin dependency: C:\Users\admin\Desktop\workspace\firebaseInit\node_modules\tns-core-modules-widgets\platforms\android\widgets-release.aar
registerResGeneratingTask is deprecated, use registerGeneratedResFolders(FileCollection)
registerResGeneratingTask is deprecated, use registerGeneratedResFolders(FileCollection)
registerResGeneratingTask is deprecated, use registerGeneratedResFolders(FileCollection)
registerResGeneratingTask is deprecated, use registerGeneratedResFolders(FileCollection)
C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values-v26\values-v26.xml:9:5-12:13: AAPT: error: resource android:attr/colorError not found.

C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values-v26\values-v26.xml:13:5-16:13: AAPT: error: resource android:attr/colorError not found.

C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values-v26\values-v26.xml:17:5-93: AAPT: error: style attribute 'android:attr/keyboardNavigationCluster' not found.

C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values\values.xml:252:5-69: AAPT: error: resource android:attr/fontStyle not found.

C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values\values.xml:252:5-69: AAPT: error: resource android:attr/font not found.

C:\Users\admin\.gradle\caches\transforms-1\files-1.1\appcompat-v7-27.0.2.aar\b2ec18b30069b5eabb6bce85e3d82017\res\values\values.xml:252:5-69: AAPT: error: resource android:attr/fontWeight not found.


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:processDebugResources'.
> Failed to process resources, see aapt output above for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 5m 59s
Unable to apply changes on device: 192.168.179.101:5555. Error is: Command gradlew.bat failed with exit code 1.

C:\Users\admin\Desktop\workspace\firebaseInit>tns run android  --stacktrace
The option 'stacktrace' is not supported. To see command's options, use '$ tns help run'. To see all commands use '$ tns help'.

C:\Users\admin\Desktop\workspace\firebaseInit> --stacktrace
'--stacktrace' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\admin\Desktop\workspace\firebaseInit>tns run  --stacktrace android
The option 'stacktrace' is not supported. To see command's options, use '$ tns help run'. To see all commands use '$ tns help'.

im trying to connect to firebase from past month and im getting these kinda errors. thats why i moved to kinvey. but i really i want to use firebase. any one guide me please…

please any one share working code here…


#2

i found the answer…

one need to create the project name in firebase such that it should match the name of nativescript project…