Unable to build app - DexArchiveMergerException


#1

Over the last 2 days, I’ve been unable to build my app. All was OK earlier; something was upgraded (I am assuming without my knowledge) and I’m now getting this error when trying to build/run/debug my app:

  • What went wrong:
    Execution failed for task ‘:app:transformDexArchiveWithExternalLibsDexMergerForDebug’.

com.android.builder.dexing.DexArchiveMergerException: Error while merging dex archives:
platforms/android/app/build/intermediates/transforms/dexBuilder/debug/74.jar, …

I’ve looked around, found relevant “fixes” by including multiDexEnabled true and other references (exclude guava-jdk5 and so on) - nothing fixes it for me. I’ve tried building the Android app on Windows and on Linux - exactly the same error.

I’ve tried to build using Sidekick, too - that just fails with no errors displayed - just says “Build failed”.

Help!


#2

@nmandyam did you find solution? facing same issue.


#3

I had moved from the old Nativescript Pro UI sidedrawer and chart to the new separate-plugins model (here is a blog about that: https://docs.telerik.com/devtools/nativescript-ui/migration). But I had not removed the nativescript-pro-ui plugin (the first thing that the blog tells you to do). And I had used the pro version on a couple of pages in my app. So an upgrade (as I said in my original statement) triggered the problem. I removed the pro-ui plugin and replaced all references to it, all worked out OK.