TypeError: this._android.setAllowEdgeSwipe is not a function


#1

I am getting this error after installing the new nativescript-ui-sidedrawer plugin.
TypeError: this._android.setAllowEdgeSwipe is not a function
Previously when I was using nativescript-pro-ui plugin, this didn’t came.
Has anyone faced the same issue ?
My environment information
nativescript -4.2.1
tns-core-modules -4.2.0
tns-android - 4.2.0


#2

I have solved this issue by commenting this line in rad side drawer plugin js file.
After doing this , my build works and I can see my side drawer,but it is below the action bar , previously it was above that and it was looking good. Now I could not make it appear above the action bar and the latest version tells that by default it will appear above the action bar and property is not needed to achieve that.
But it is not so ? Has anyone have the same problem or what am I doing wrong ?


#3

Is the RadSideDrawer set as root of your application?


#4

Sir, No it is not set as the root of the application and it is written in specific xml inside the application.


#5

Try setting it as root of your application, it should adjust action bar itself.


#6

Ok sir Thanks … I will check.