TSC not executed on "tns run"

nativescriptcore

#1

Hi,
I’m trying to use the HtmlView component to render a formatted text.
As a start, I’m using the same source as shown in https://docs.nativescript.org/angular/code-samples/ui/htmlview

But when trying to execute the sample, I see this exception:

System.err: com.tns.NativeScriptException: 
System.err: Calling js method onCreateView failed
System.err: 
System.err: TypeError: Cannot read property 'search' of undefined
System.err: File: "file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/html-view/html-view.js, line: 30, column: 17
System.err: 
System.err: StackTrace: 
System.err: 	Frame: function:'HtmlView.(anonymous function)', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/html-view/html-view.js', line: 30, column: 18
System.err: 	Frame: function:'applyAllNativeSetters', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/properties/properties.js', line: 961, column: 28
System.err: 	Frame: function:'initNativeView', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/properties/properties.js', line: 905, column: 9
System.err: 	Frame: function:'ViewBase.onResumeNativeUpdates', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/view-base/view-base.js', line: 555, column: 22
System.err: 	Frame: function:'ViewBase._resumeNativeUpdates', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/view-base/view-base.js', line: 223, column: 18
System.err: 	Frame: function:'ViewBase.onLoaded', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/view-base/view-base.js', line: 200, column: 14
System.err: 	Frame: function:'View.onLoaded', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/view/view.js', line: 62, column: 35
System.err: 	Frame: function:'', file:'file:///data/data/com.sample.app/files/app/tns_modules/tns-core-modules/ui/core/view-base/view-base.js', line: 206, column: 19

It turns out that this problem was caused as my .ts files were not compiled to js on ‘tns run’ and thus, the data I would pass for the HtmlView was not there.

Does somebody have a hint for me by which setting I can re-enable the executon of the typescript compiler?