Tns update 3.2.1 not working


#1

After running tns doctor, it says 3.2.1 update is available. I removed ios and android platforms.

I ran tns update but it kept the project at 3.2.0 without any error messages. tns doctor confirms the project is still on 3.2.0.

I tried tns update 3.2.1 but I get the message

Invalid platform 3.2.1. Valid platforms are ios or android.

Which seems really odd since both platforms were already removed.

How can I update my project to 3.2.1?


#2

tns platform add android
tns platform add ios

tns plugin remove tns-core-modules
tns plugin add tns-core-modules

These lines will update your nativescript components. 3.2.1 is a CLI release, and there are no 3.2.1 versions for the runtimes AFAIK.


#3

tns doctor still shows current version 3.2.0 and that 3.2.1 is available.

Is tns doctor showing me the CLI version? or the components?


#4

When inside the dir of a {N} project - tns info will return CLI version, modules version, added runtimes version. When outside, tns info will only display the CLI version.

I am assuming that tns doctor shows the current CLI version, as it isn’t aware of the directory it is executed in.


#5

I’m still not sure what’s preventing me from updating to CLI 3.2.1. This is on a Mac. npm version is 5.4.1 node version is 6.11.3

I’ve tried creating a new project and it gives me the same issues.


#6

Hi @steveoliverc, the command tns update will update your project, not CLI. If you want to update CLI do:

  • npm uninstall -g nativescript
  • npm clear cache
  • npm install -g nativescript

The command ths update <version> is currently not working, we’ll investigate.


#7

thanks @plamen5kov that did the trick! also it fixed my issue with Sidekick which wouldn’t run without CLI 3.2.1.


#8

Does not work for me :
I tried @plamen5kov’s answer, it does not update my project’s package.json
So I did tns update after but command line gets stuck in VisualStudioCode (as before)

It is problematic as new modules start to need new versions :frowning: