Tns run android is not runing app in mac


#1

Hello everyone,

I was able to run following commands without problem.

tns run ios

However, when I tried to run tns run android, it got stuck at following and it didn’t open anything

Total time: 5.543 secs
Project successfully built.
Installing...

when I stop it then it showed me following lines at terminal

Successfully installed on device with identifier 'emulator-5554'.
Terminated: 15
Successfully transferred all files
Refreshing application...
TypeScript compiler failed with exit code null

I have mac, I have install all necessary steps from nativestcript

Any Suggestions ??


#2

I had the same issue, and found that below ID in package.json

“nativescript”: {
“id”: “com.test.App”

is different from the applicationId in app.gradle

defaultConfig {
generatedDensities = []
applicationId =“com.nativescript.App”

After changing them both to the same name app getting launched with tns run android.


#3

I had same id in package.json and application_id app.gradle are same. However, it still doesn’t work