Tns does not compile anymore; Found 0 errors. Watching for file changes

android

#1

I’m trying to finish the egghead.io course about NativeScript Angular.

I’m in last lession and tns does not compile anymore.
I tried to clean, remove or add android. Nothing

Compile output:

Found peer node-sass

Executing before-watch hook from /home/paneladm/projects/native-script-classes/ng-native-egghead.io/hooks/before-watch/nativescript-dev-typescript.js
Found peer TypeScript 2.9.1

02:00:58 - Starting compilation in watch mode...

02:01:16 - Found 0 errors. Watching for file changes.

I thought I upgrade the tns-android to 4.1.1 solved it but nothing.
Now my dependencies version is below:

	"nativescript": {
		"id": "org.nativescript.ngnativeeggheadio",
		"tns-android": {
			"version": "4.1.1"
		}
	},
	"dependencies": {
		"@angular/animations": "~5.2.0",
		"@angular/common": "~5.2.0",
		"@angular/compiler": "~5.2.0",
		"@angular/core": "~5.2.0",
		"@angular/forms": "~5.2.0",
		"@angular/http": "~5.2.0",
		"@angular/platform-browser": "~5.2.0",
		"@angular/platform-browser-dynamic": "~5.2.0",
		"@angular/router": "~5.2.0",
		"nativescript-angular": "^5.2.0",
		"nativescript-checkbox": "^3.0.3",
		"nativescript-theme-core": "~1.0.4",
		"reflect-metadata": "^0.1.12",
		"rxjs": "^5.5.11",
		"tns-core-modules": "^4.1.0",
		"zone.js": "^0.8.26"
	},
	"devDependencies": {
		"babel-traverse": "6.26.0",
		"babel-types": "6.26.0",
		"babylon": "6.18.0",
		"lazy": "1.0.11",
		"nativescript": "^4.0.2",
		"nativescript-dev-sass": "^1.5.0",
		"nativescript-dev-typescript": "~0.7.0",
		"typescript": "^2.6.2"
	}

Environments:

I’m using Node as nvm v8.11.2

:heavy_check_mark: Getting environment information

No issues were detected.
:heavy_check_mark: Your ANDROID_HOME environment variable is set and points to correct directory.
:heavy_check_mark: Your adb from the Android SDK is correctly installed.
:heavy_check_mark: The Android SDK is installed.
:heavy_check_mark: A compatible Android SDK for compilation is found.
:heavy_check_mark: Javac is installed and is configured properly.
:heavy_check_mark: The Java Development Kit (JDK) is installed and is configured properly.
:heavy_check_mark: Local builds for iOS can be executed only on a macOS system. To build for iOS on a different operating system, you can use the NativeScript cloud infrastructure.
:heavy_check_mark: Getting NativeScript components versions information…
:heavy_check_mark: Component nativescript has 4.1.0 version and is up to date.
:heavy_check_mark: Component tns-core-modules has 4.1.0 version and is up to date.
:heavy_check_mark: Component tns-android has 4.1.1 version and is up to date.
:heavy_multiplication_x: Component tns-ios is not installed.

Anyone can help me?


#2

Thank’s, @bradwaynemartin for your help! :slight_smile:

I’m using now Node.js as nvm to manage multiple node.js version, I think this create a confuse cache to my npm global.

To fix it I follow this steps:

  • Remove the npm global cache using --force like this: npm cache clean --force
  • Remove the folders: node_modules, hooks, platforms
  • Now change the dependencies version as below:
  • tns-android: version": "4.1.1
  • nativescript-angular: ~5.3.0
  • reflect-metadata: ~0.1.10
  • rxjs: ~5.5.5
  • tns-core-modules: ~4.0.0
  • zone.js: ~0.8.18
  • typescript: ~2.7.2

RE: Suspect rxjs@6.2.0 issue
#3

I cleaned the cache, deleted the node_modules and hooks directories, then removed both platforms (with CLI) and removed the remaining files in the folder. After that I run npm uninstall -g nativescript, then npm install -g nativescript@latest, tns platform add android@latest.

This did not solved my problem, the command is still stuck on Found 0 errors. Watching for file changes..
Do you have any suggestion on some things I might have missed ?
(This happened after I had tried to tweak the typescript version)


#4

So… I follow this steps, remove all npm cache and remove node_modules, hooks, platforms and change the dependencies version to a specific one (I mentioned on the post)


#5

Ok so I followed word to word what you said, and set the exact dependencies versions (mine were different the previous time). After that I ran tns doctor which reinstalled all the modules and the correct dependencies versions. I finally ran tns platform add android and my app is now launching !
Thank you for your time


#6

This can be resolved by installing the nativescript-dev-typescript@next package.
Why? This is why: https://github.com/NativeScript/nativescript-dev-typescript/commit/84496145c9a8bb865ea2b80d3dc317a9416b3493