Tns - command not found - MAC


#1

Trying to use nativescript-vue - going through the step by step tutorial. Went through the entire set up for nativescript. Got NO errors the entire time. Then, at the very end, tried to use tns. Returned, command not found. Closed and reopened terminal. Everything installed is up to date and meeting specifications, but still not working.

rb-mac-007:~ stevengissubel$ npm install -g nativescript

> nativescript@4.1.2 preuninstall /Users/stevengissubel/.npm-global/lib/node_modules/nativescript
> node preuninstall.js

/Users/stevengissubel/.npm-global/bin/tns -> /Users/stevengissubel/.npm-global/lib/node_modules/nativescript/bin/tns
/Users/stevengissubel/.npm-global/bin/nativescript -> /Users/stevengissubel/.npm-global/lib/node_modules/nativescript/bin/tns

> nativescript@4.1.2 postinstall /Users/stevengissubel/.npm-global/lib/node_modules/nativescript
> node postinstall.js

Autocompletion is already enabled

Installation successful. You are good to go. Connect with us on http://twitter.com/NativeScript.

You have successfully installed NativeScript CLI.
In order to create a new project, you can use:
tns create <app name>

To build your project locally you can use:
tns build <platform>

NOTE: Local builds require additional setup of your environment. You can find more information here: https://docs.nativescript.org/start/quick-setup


To build your project in the cloud you can use:
tns cloud build <platform>

NOTE: Cloud builds require Telerik account. You can find more information here: https://docs.nativescript.org/sidekick/intro/requirements

In case you want to experiment quickly with NativeScript, you can try the Playground: https://play.nativescript.org

In case you have any questions, you can check our forum: https://forum.nativescript.org and our public Slack channel: https://nativescriptcommunity.slack.com/

+ nativescript@4.1.2
updated 1 package in 4.921s
rb-mac-007:~ stevengissubel$ tns
-bash: tns: command not found

#2

Which version of node you are using?
Did you try closing and reopening the terminal?
Are you using the default terminal or anything customised?