System Cannot find the path specified


#1

When I try to install the pre-requisites (doing so as Admin) on windows, the installation doesn’t cmplete properly and it fails on emulator installation.
Please guide, someone. Thanks


#2

Since we do not have access to your system, we’d appreciate if you provided more info regarding its current state.
What installed, what didn’t?
At what point did the installation error out?
Are there any error messages?
What steps did you follow to get where you are now?


#3

I have gotten past the installation to the point where tns doctor returns success (no issues). However, when I run the hello world, I get the traditional and the most annoying error:

“Cannot run your app in the native emulator. Increase the timeout of the operation with the --timeout option or try to restart your adb server with ‘adb kill-server’ command. Alternatively, run the Android Virtual Device manager and increase the allocated RAM for the virtual device”

I am on windows, and really could use some help. Thanks in advance.


#4

Have you started an emulator through the avdmanager, or through Android Studio’s Tools submenu? Have you installed any emulator images from the sdkmanager? You need to have at least one of those on your system to be able to fire up an emulator.

Alternatively you could download and setup Genymotion emulators for Android - https://www.genymotion.com/


#5

Yes I did. I get the same error in red color repeatedly. When I run the AVD
Manager’s green triangle RUN icon, it simply says “Starting AVD” in the
status bar (bottom) of Android Studio.
Please help.


#6

Another quick question, genymotion isn’t free, or is it? I see that I’ll need a license of atleast $136 per year. Am I right?


#7

If Android Studio doesn’t start up the emulator, you might want to troubleshoot the reasons behind it.

As for Genymotion - it’s got a Trial that is (was?) very forgiving that should allow you to run your apps in their Emulators.

And if all else fails - plug in an Android device with Developer Mode and USB Debugging enabled to run your app on.


#8

Ok and Thank you. Geny worked. So at least I am doing something. Appreciate your help.