Signed apk to emulator


#1

hi there,i was tried run signed apk to android emulator but it wont work on it.

tns run android --key-store-path C:\users\myapp\key.jks --key-store-password alex1234–key-store-alias myapp --key-store-alias-password alex1234


#2

What doesn’t work for you, Alex? I noticed that you are missing the --release flag, as well as a space between your key-store-password and the key-store-alias.

You are more likely to get quality responses and help on the forum if you provide more information about your particular cases.


#3

Hi peter,i was try to make a google login via firebase plugin to my app but it keep showing this error message "missing sha1 key "when run in emulator.
It only worked when i bulid the apk and put it virtual device

tns run android --release --key-store-path C:\users\myapp\key.jks --key-store-password alex1234 --key-store-alias myapp --key-store-alias-password alex1234


#4

What does Google have to say about this? We still don’t have the complete picture, nor do we know the actual error message that you are seeing, so we can do a looot of guessing and waste a lot of time.


#5

Hi Peter,this is the error message show to me

JS: Make sure you’ve uploaded your SHA1 fingerprint(s) to the Firebase console
JS: “service:Has the SHA1 fingerprint been uploaded? Sign-in status: Status{statusCode=unknown status code: 12501, resolution=null}”

Beside, i was uploaded the sha1 fingerprint to firebase and download the latest google.service.json


#6

Hi peter
i was found a way to run signed apk to android emulator

1)npm clean
2)tns platform remove android
3)tns run android --release --key-store-path C:\users\myapp\key.jks --key-store-password alex1234 --key-store-alias myapp --key-store-alias-password alex1234

but it wont work and showing the same error message sometime,so had to repeat the same step as top again


#7

Hey, Alex, I have problem too. Did you manage to solve this issue?

I already pasted the certificate hash for my debug.keystore on the Firebase console, downloaded the google-services.json to the app/App_Resources/android directory but I’m unable to login with Google, is keeps saying “Has the SHA1 fingerprint been uploaded?” =/