SideKick Android Cloud Build failed Invalid Filename


#1

My app is compiling ok from cloud for iOS Release. When I’m trying to do the same for Android, I get the “Invalid Filename” error, just after asking for the password of my certificate which I have previously created :

keytool -genkey -v -keystore release.keystore -alias Selector -keyalg RSA -keysize 2048 -validity 10000

The certificate is working fine with Adobe Phonegap Build, so I think the problem is my Nativescript app config…

Any idea?


#2

i get the same problem too. have you got solution for it??


#3

i have tried many ways and finally i got it. what i do i will explain it below.

  1. Use your text editor in my case i use notepad++ to find Invalid filename in Nativescript Folder and you will find it on file errors.js in path node_modules/adm-zip/util/errors.js line 33
  2. On line 33 you will find “INVALID_FILENAME” : “Invalid filename”, it means error of “Invalid filename” will refers to “INVALID_FILENAME”
  3. Use your text editor again to find INVALID_FILENAME and you will got it on file adm-zip.js line 19.
  4. On line 19 you will find throw Utils.Errors.INVALID_FILENAME;
  5. change line 19 to throw Utils.Errors.INVALID_FILENAME+’ '+input;
  6. Run the release and you will got the truly error. And i find it that new nativescript cli change directories of libs, metadata and src in your platform/android to new path inside app. So copy them outside of folder app and run the release once again you will got the release file.

#4

After changing this line as you suggest, and:

1.delete hooks & node_modules
2.remove “nativescript-dev-android-snapshot”: “^0..” from package.json

Local release build now works from terminal or SideKick,
but no luck with cloud yet where I got now this error: Only 8, 16, 24, or 32 bits supported: 872


#5

Thanks a lot… This error had been a great issue for a month and finally this worked…


#6

I’m facing the exact same issue. The error I’m getting is ‘Invalid filename platforms\android\libs\runtime-libs\nativescript.aar’. Can you please explain the step 6 you have mentioned a bit further? Did you copy the src directory into the ‘libs\runtime-libs’ directory?


#7

I was able to solve the issue. To supplement @shafrudin’s answer, I had to copy the nativescript\platforms\android\app\libs directory into nativescript\platforms\android and the release build was successful.


#8

Yes. Me too had the same issue and this method works perfectly.