Really need help: Debugger unexpectedly closes on file save and complains about not finding ts_helpers.js


#1

Recently i have started getting 2 strange problems with the debugger in VSC. I’ve spent a lot of time trying to fix it. While doing that i’ve uninstalled, reinstalled, and upgraded everything from Android SDK and its components, to Nativescript and Typescript, and finally VSC. In the end the problem persists even with a clean new project from Nativescript template. Google search returns nothing at all. At this point any help is desperately needed and much appreciated.

Problem 1:
When running debugger from VSC even with “watch”: true (see config below) the debug session prints message below to the debug console and then shuts down. Both debug toolbar in VSC and android emulator (both google and genymotion) closes by themselves. The strangest part is that it used to work until recently but rolling back now does not solve the problem.

output to debug console:

6:28:06 PM - File change detected. Starting incremental compilation...
6:28:06 PM - Found 0 errors. Watching for file changes.
Successfully transferred home-page.xml.

Problem 2:
when adding “stopOnEntry”: true to the debug configuration VSC shows the following error despite the fact that the file does exist. Once again google searching did not return anything relevant.

Unable to open 'ts_helpers.js': File not found (file:///data/data/apppackagename/files/internal/ts_helpers.js).

Debug configuration:

        {
            "name": "Launch on Android",
            "type": "nativescript",
            "request": "launch",
            "platform": "android",
            "appRoot": "${workspaceRoot}",
            "sourceMaps": true,
            "watch": true,
            "sourceMapPathOverrides": {
                "webpack:///*": "${workspaceRoot}/app/*"
            }
        }

Please help. Debugging has turned into a time consuming and frustrating process.


#2

You say you’re debugging in VSC. Have you tried using Chrome?


#3

Haven’t tried that. VSC has been working great until now.


#4

Apparently this issue has already been reported and people much smarter than I are already working on the fix.

But the “ts_helpers.js not found” problem is still bewildering.