Raddataform: Adjust Editors with XML does not work


#1

Raddataform: Adjust Editors with XML wont work, look like it ignore the code in the html.

Test.component.html:

test.component.ts:
import { Component, OnInit } from ‘@angular/core’;
import * as app from ‘tns-core-modules/application/application’;
import { RadSideDrawer } from ‘nativescript-ui-sidedrawer’;

import { Person } from ‘./models/person’;

@Component({
selector: ‘ns-testings’,
moduleId: module.id,
templateUrl: ‘./test.component.html’
})
export class TestComponent implements OnInit {
private _person: Person;
constructor() {
// Use the component constructor to inject providers.
}

ngOnInit(): void {
    this._person = new Person("John", 23, "john@company.com", "New York", "5th Avenue", 11);
}

onDrawerButtonTap(): void {
    const sideDrawer = <RadSideDrawer>app.getRootView();
    sideDrawer.showDrawer();
}

get person(): Person {
    return this._person;
}

}

the result

as you can see the display name and group do not work. look like the display name… are all from the source.

below is my package.json:
“dependencies”: {
@angular/animations”: “~6.0.6”,
@angular/cli”: “^6.0.8”,
@angular/common”: “~6.0.6”,
@angular/compiler”: “~6.0.6”,
@angular/core”: “~6.0.6”,
@angular/forms”: “~6.0.6”,
@angular/http”: “~6.0.6”,
@angular/platform-browser”: “~6.0.6”,
@angular/platform-browser-dynamic”: “~6.0.6”,
@angular/router”: “~6.0.6”,
@ngrx/effects”: “^6.0.1”,
@ngrx/store”: “^6.0.1”,
@ngx-translate/core”: “^10.0.2”,
@ngx-translate/http-loader”: “^3.0.1”,
“nativescript-angular”: “^6.0.6”,
“nativescript-drop-down”: “^4.0.1”,
“nativescript-fancyalert”: “^1.2.0”,
“nativescript-ngx-fonticon”: “^4.2.0”,
“nativescript-theme-core”: “~1.0.4”,
“nativescript-ui-chart”: “^3.7.0”,
“nativescript-ui-dataform”: “^3.6.2”,
“nativescript-ui-sidedrawer”: “~4.0.0”,
“reflect-metadata”: “~0.1.10”,
“rxjs”: “~6.2.1”,
“tns-core-modules”: “4.0.1”,
“zone.js”: “^0.8.26”
},
“devDependencies”: {
@angular/compiler-cli”: “~6.0.7”,
@ngtools/webpack”: “~1.9.4”,
“babel-traverse”: “6.26.0”,
“babel-types”: “6.26.0”,
“babylon”: “6.18.0”,
“clean-webpack-plugin”: “~0.1.19”,
“codelyzer”: “~4.0.2”,
“copy-webpack-plugin”: “~4.3.0”,
“css-loader”: “~0.28.7”,
“extract-text-webpack-plugin”: “~3.0.2”,
“lazy”: “1.0.11”,
“nativescript-dev-sass”: “~1.5.0”,
“nativescript-dev-typescript”: “~0.7.0”,
“nativescript-dev-webpack”: “~0.10.0”,
“nativescript-worker-loader”: “~0.8.1”,
“raw-loader”: “~0.5.1”,
“resolve-url-loader”: “~2.2.1”,
“sass-loader”: “~6.0.6”,
“tslint”: “~5.8.0”,
“typescript”: “~2.7.2”,
“uglifyjs-webpack-plugin”: “~1.1.6”,
“webpack”: “~3.10.0”,
“webpack-bundle-analyzer”: “^2.9.1”,
“webpack-sources”: “~1.1.0”
}

please help.

Best Regards