Problem with installing nativeScript


#1

I have tried to install nativeScript, but i keeps saying that the AndroidSDK has not been installed, but the installer has installed it every time and I tried to uninstall it completely and reinstall it with the installer when it’s finished I see this

Environment Vars (like PATH) have changed. Close/reopen your shell to
 see the changes (or in powershell/cmd.exe just type `refreshenv`).
 The install of android-sdk was successful.
  Software installed to 'C:\Android\android-sdk'

Chocolatey installed 1/1 packages.
 See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
Do you want to install Android emulator?: y
Do you want to install HAXM (Hardware accelerated Android emulator)?: y
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
The chosen path was not fund.
This script has modified your environment. You need to log off and log back on for the changes to take effect.
Press any key to continue...

and when I run tns doctor I get this error

WARNING: adb from the Android SDK is not installed or is not configured properly.
For Android-related operations, the NativeScript CLI will use a built-in version of adb.
To avoid possible issues with the native Android emulator, Genymotion or connected
Android devices, verify that you have installed the latest Android SDK and
its dependencies as described in http://developer.android.com/sdk/index.html#Requirements

TIP: To avoid setting up the necessary environment variables, you can use the chocolatey package manager to install the Android SDK and its dependencies.

WARNING: The Android SDK is not installed or is not configured properly.
You will not be able to build your projects for Android and run them in the native emulator.
To be able to build for Android and run apps in the native emulator, verify that you have
installed the latest Android SDK and its dependencies as described in http://developer.android.com/sdk/index.html#Requirements

TIP: To avoid setting up the necessary environment variables, you can use the chocolatey package manager to install the Android SDK and its dependencies.

NOTE: You can develop for iOS only on Mac OS X systems.
To be able to work with iOS devices and projects, you need Mac OS X Mavericks or later.

The ANDROID_HOME environment variable is not set or it points to a non-existent directory. You will not be able to perform any build-related operations for Android.
To be able to perform Android build-related operations, set the ANDROID_HOME variable to point to the root of your Android SDK installation directory.

Cannot find a compatible Android SDK for compilation. To be able to build for Android, install Android SDK 22 or later.
Run $ sdkmanager to manage your Android SDK versions.

You need to have the Android SDK Build-tools installed on your system. You can install any version in the following range: '>=23 <=26'.
Run $ sdkmanager from your command-line to install required Android Build Tools. In case you already have them installed, make sure ANDROID_HOME environment variable is set correctly.

You need to have Android SDK 22 or later and the latest Android Support Repository installed on your system.
Run $ sdkmanager to manage the Android Support Repository. In case you already have it installed, make sure ANDROID_HOME environment variable is set correctly.

There seem to be issues with your configuration.

What can the problem be?
I’m running a windows 10 computer


#2

go on your command line and type “android”

Then install all the nativescript requirements ,which are, and i quote from the tutorial:

Install all packages for the Android SDK Platform 25, Android SDK Build-Tools 25.0.2 or later, Android Support Repository, Google Repository and any other SDKs that you may need. You can alternatively use the following command, which will install all required packages.

"%ANDROID_HOME%\tools\bin\sdkmanager" "tools" "platform-tools" "platforms;android-25" "build-tools;25.0.2" "extras;android;m2repository" "extras;google;m2repository"

#3

this is what i get when I run that command, witch I also have tried The chosen path was not fund.


#4

Encountered the error when I ran the code