Problem with google services and android build


#1

Hi,
I’ve done an app for IOS that’s working fine, but now i want to experiment with the Android.
Right now i’m facing this issue:

FAILURE: Build failed with an exception (CONSOLE).

* What went wrong:
Execution failed for task ':app:processDebugGoogleServices'.
> Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/android/android-tools/com.google.gms.google-services/) or updating the version of com.google.android.gms to 11.8.0.

App_resources/app.gradle:

android {
    defaultConfig {
        generatedDensities = []
        applicationId = "com.my.my"
    }
}
dependencies {
    compile 'com.google.android.gms:play-services-maps:11.8.0'
    compile 'com.google.android.gms:play-services-location:11.8.0'
    compile 'com.android.support:recyclerview-v7:26.1.0'
}
apply plugin: 'com.google.gms.google-services'

package.json:

{
  "description": "NativeScript Application",
  "license": "SEE LICENSE IN <your-license-filename>",
  "readme": "NativeScript Application",
  "repository": "<fill-your-repository-here>",
  "nativescript": {
    "id": "com.my.my",
    "tns-ios": {
      "version": "4.1.1"
    },
    "tns-android": {
      "version": "4.1.3"
    }
  },
  "dependencies": {
    "nativescript-dom": "^2.0.0",
    "nativescript-drop-down": "^3.2.4",
    "nativescript-effects": "^1.0.0",
    "nativescript-filterable-listpicker": "^2.0.2",
    "nativescript-google-maps-sdk": "^2.6.0",
    "nativescript-grid-view": "^4.0.0",
    "nativescript-https": "^1.0.1",
    "nativescript-ios-uuid": "^1.0.0",
    "nativescript-iqkeyboardmanager": "^1.3.0",
    "nativescript-loading-indicator": "^2.4.0",
    "nativescript-localstorage": "^1.1.5",
    "nativescript-numeric-keyboard": "^4.0.2",
    "nativescript-platform-css": "^1.6.5",
    "nativescript-push-notifications": "^1.1.4",
    "nativescript-theme-core": "^1.0.4",
    "nativescript-toast": "^1.4.6",
    "nativescript-ui-sidedrawer": "^3.5.0",
    "nativescript-zxing": "^1.5.6",
    "npm": "^5.8.0",
    "tns-core-modules": "^4.1.0"
  },
  "devDependencies": {
    "babel-traverse": "6.26.0",
    "babel-types": "6.26.0",
    "babylon": "6.18.0",
    "clean-webpack-plugin": "~0.1.19",
    "copy-webpack-plugin": "~4.3.0",
    "css-loader": "~0.28.7",
"extract-text-webpack-plugin": "~3.0.2",
"lazy": "1.0.11",
"nativescript-dev-sass": "^1.5.0",
"nativescript-dev-webpack": "^0.11.0",
"nativescript-worker-loader": "~0.8.1",
"raw-loader": "~0.5.1",
"resolve-url-loader": "~2.2.1",
"sass-loader": "~6.0.6",
"uglifyjs-webpack-plugin": "~1.1.6",
"webpack": "~3.10.0",
"webpack-bundle-analyzer": "^2.9.1",
"webpack-sources": "~1.1.0"

}
}

What is wrong guys ?
Why build is moaning about updating google services?
Thanks.!


#2

I don’t have a specific answer for you, but in similar circumstances I’ve deleted the platforms folder and rebuilt and all is good. It’s worth trying at least.


#3

Thank you @roblauer, but it’s now working for me…
Cheers !