Plugin issue: TypeError: Invalid Version: 2.0.0


#1

Hi,
I am creating a plugin.

When I add the plugin ( tns plugin add …/plugins/crypter ) I get this output:

Successfully installed plugin nativescript-crypter.
TypeError: Invalid Version: ​2.0.0
at new SemVer (C:\Users\Fer\AppData\Roaming\npm\node_modules\nativescript\node_modules\semver\semver.js:293:11)

This is the plugin package.json:

{
“name”: “nativescript-crypter”,
“version”: “0.0.1”,
“description”: “Test”,
“main”: “index.js”,
“nativescript”: {
“platforms”: {
“android”: “​2.0.0”
}
}
}

This is the plugin structure:
Captura

Plase can you help me?


#2

Solved.
I changed the structure ti this, and it works!.
Captura1