Only changing the app folder name helps to fix the problem


Hi there!

Very strange thing but maybe I just don’t know something.
If I get any problems during the running the app with Sidekick and then I fix the errors, I again see the same errors in the log file. The only way how to start the app after fixing the errors is to change the app folder name.

Can anybody tell where is the problem? Thank you!


Haven’t tried Sidekick for debugging (I only use it to create apps and manage permissions), but try VS code it is way more advance and capable for debugging, and see if the same problem persist


So the only way to fix the problem with Sidekick is not to use Sidekick? =)


lol no not like that :stuck_out_tongue: I’m telling you from my experience Sidekick is an awesome tool for starter templates, plugins, cloud builds, permission management, …etc but honestly not for debugging. because as a developer you need really capable IDE thats why I said you should give vs code a try.

back to your original problem, if you run dubbing from the terminal directly, then do you see the same behaviour?


Now I’ve realized that I can’t run the app from the terminal (I haven’t tried this for a long time already). I see this error:

C:\Users\Nikita\firebase-old\App>tns run android
Searching for devices...
Skipping prepare.
Building project...
Gradle build...
Unzipping C:\Users\Nikita\.gradle\wrapper\dists\gradle-3.3-bin\64bhckfm0iuu9gap9
hg3r7ev2\ to C:\Users\Nikita\.gradle\wrapper\dists\gradle-3.3-
Exception in thread "main" error in opening zip file

        at Method)
        at org.gradle.wrapper.Install.unzip(
        at org.gradle.wrapper.Install.access$600(
        at org.gradle.wrapper.Install$
        at org.gradle.wrapper.Install$
        at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAcc
        at org.gradle.wrapper.Install.createDist(
        at org.gradle.wrapper.WrapperExecutor.execute(
        at org.gradle.wrapper.GradleWrapperMain.main(
Unable to apply changes on device: 0aef245f02b5b0dc. Error is: Command gradlew.b
at failed with exit code 1.


seems like this zip file is damaged, try to replace it with a new You can download it from here


Or, you can navigate to the user directory, delete the .gradle directory, and run the application again, that should be enough to force redownload of the gradle wrapper package on your workstation.


Thank you for your advice! I’m quite new in Nativescript and still don’t know how can I solve some problem. So, I’ve made debug from terminal and I’ve found a lot of problems in my app. After I fixed all errors I was able to run it and I even got the original name of the app.

But if I try to use Sidekick I’m still getting the old error which I’ve already fixed. It’s very strange. I try to launch the app with cloud build, so maybe there is some cached data in the cloud. But in this case how it could be cleaned? It’s just my assumption and maybe there is another problem?


you can delete the following folders /platforms, /hooks and /node_modules, and then run again. it will do clean build


No, it doesn’t work. It says that I have duplicated recourses but I don’t. I can run the app with the terminal but not in Sidekick. Seems like there is only option not to use Sidekick. But in the nearest future I would like to run the app on iOS using Sidekick because I don’t have Mac. Oh… how difficult…

[17-12-07 21:38:51.721] (Info) FAILURE: Build failed with an exception.
[17-12-07 21:38:51.724] (Info) * What went wrong:
[17-12-07 21:38:51.724] (Info) Execution failed for task ':mergeF0F1F2F3DebugResources'.
[17-12-07 21:38:51.726] (Info) > [drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.xml\t[drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.png\t[drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.9.png: Error: Duplicate resources
[17-12-07 21:38:51.729] (Info) [drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.xml\t[drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.png\t[drawable-nodpi-v4/splashscreen] /mnt/storage/builds/_/5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7/Geopes/platforms/android/src/main/res/drawable-nodpi/splashscreen.9.png: Error: Duplicate resources
[17-12-07 21:38:51.731] (Info) * Try:
[17-12-07 21:38:51.734] (Info) Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
[17-12-07 21:38:51.736] (Info) Command ./gradlew failed with exit code 1
[17-12-07 21:38:51.739] (Info) bc_5d4f1565ae92b47aa8c73afeb35fa8ff4c7af6b7_rLIXqoQKrieLkX6EAc
[17-12-07 21:38:53.624] (Error) Error detected during LiveSync on 0aef245f02b5b0dc for C:\Users\Nikita\firebase-old\Geopes. Error: Build failed.
[17-12-07 21:38:53.656] (Info) Stopped LiveSync on 0aef245f02b5b0dc for C:\Users\Nikita\firebase-old\Geopes.
[17-12-07 21:38:53.661] (Error) Couldn't enable debugging for 0aef245f02b5b0dc, Error: Couldn't enable debugging for 0aef245f02b5b0dc
    at (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\common\errors.js:125:28)
    at Errors.failWithoutHelp (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\common\errors.js:133:21)
    at LiveSyncService.<anonymous> (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\services\livesync\livesync-service.js:225:30)
    at (<anonymous>)
    at C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\services\livesync\livesync-service.js:13:71
    at new Promise (<anonymous>)
    at __awaiter (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\services\livesync\livesync-service.js:9:12)
    at LiveSyncService.enableDebuggingCoreWithoutWaitingCurrentAction (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\services\livesync\livesync-service.js:222:16)
    at LiveSyncService.<anonymous> (C:\Users\Nikita\AppData\Roaming\npm\node_modules\nativescript\lib\services\livesync\livesync-service.js:262:25)
    at (<anonymous>)


When you create a clean new template in sidekick and run it, do you also face the same problem?


Clean template works. But as I explained above if I face with some error and fix it, I cannot build app anymore. The error has become “saved” and I see it everytime. But If I change the name of the project’s folder, I can build the project again.


hmm that weird :thinking: maybe its a bug, you should open an issue here