NS 3 HelloWorld won't run on ios


#1

I ran into problems upgrading my current app to NativeScript 3.0 on iOS so I tried the HelloWorld tutorial and I am having the same problem.

I executed the following steps

npm install -g nativescript
tns --version
  > 3.0.0
tns create HelloWorld --template nativescript-template-ng-tutorial
cd HelloWorld
tns run ios

Everything builds and the iOS emulator launches but then I get this error:

Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.

while executing xcrun simctl install 2C26F15F-4194-4D29-AC48-24ECE8A58115 /Users/rgardner/Development/HelloWorld/platforms/ios/build/emulator/HelloWorld.app.

I tried reinstalling platform ios and a few other suggestions I found, but nothing works.

I read in the RC notes that NS 3 doesn’t support XCode 8.3 but I can’t find that in the current docs, so I’m assuming it’s fixed. I am running XCode 8.3.2.


#2

This was resolved by uninstalling and re-installing nativescript. I’m now at version 3.0.1.
I also re-ran the gem installer for xcodeproj, and cocoapods, so I’m not sure which of these steps fixed it, but most likely there was something strange with my nativescript upgrade from v2 to v3, so it was the nativescript re-install.