NS 2.5.1 IOS - Incremental build generates inconsistent binary


#1

Hello,

I have been having several issues with the CLI on nativescript.

Reference:

I just updated to V 2.5.1 and behavior is way worse than in previous version, at least for productivity.

On previous version the behavior was.
Build failed with multiple errors.
Build was not updated on the emulator.
Have to manually run again tns run.

On current version behavior is the following.
Run tns emulator for first time. (everything works fine).
On a change on code, incremental build is triggered.
Build is generated, no visible errors on console, besides the following.

com.apple.CoreSimulator.SimDevice.7FAA81AB-C46A-4489-A751-2AD35DAAAC55.launchd_sim[34349] (UIKitApplication:co.workride.app[0x3874][36908]): Service exited due to Trace/BPT trap: 5

I have different versions of that error, with different exit codes. Other exit codes are 9 and 15.

If I run tns run --emulator again, the app will still not work.
It will basically try to open and crash.

To generate a valid binary again, I will have to run tns build ios.

Same issue is not reproducible on android.

My project has plugins: i18n, card, snackbar, dropdown, geolocation, maps-sdk, toast.


#2

I’m experiencing this exact same issue with iOS and the Simulator. Also agree it’s worse than the previous behavior in 2.5.0.

I’m using a number of plugins, but we overlap with i18n, dropdown and geolocation.

We’ll try to get core team review of this problem ASAP. Definitely a painful issue for iOS workflow.


#3

Great to hear Im not the only one.
Thanks.


#4

I’ve opened an issue to track this:
https://github.com/NativeScript/nativescript-cli/issues/2557

Based on my testing today, it is 100% related to the nativescript-i18n plugin. Something weird is happening when this plugin is present that is causing the {N} build to break on LiveSync. Hopefully the core team can patch quickly now that they have a reproducible project.