Npm warning for dependncies for app that has just been created by tns create


#1

Hello all,
I am newbie in Nativescript and in angular in general so sorry if this is a stupid question.

I have just created an App using "tns create MyApp --ng"
By executing npm i i get the following two warnings

npm WARN nativescript-angular@5.3.0 requires a peer of tns-core-modules@^4.0.0 || >4.0.0- || >4.1.0- but none is installed. You must install peer dependencies yourself.
npm WARN nativescript-angular@5.3.0 requires a peer of typescript@~2.6.2 but none is installed. You must install peer dependencies yourself.

The package.json file generated (i haven’t modified it) is

{
	"description": "NativeScript Application",
	"license": "SEE LICENSE IN <your-license-filename>",
	"readme": "NativeScript Application",
	"repository": "<fill-your-repository-here>",
	"nativescript": {
		"id": "org.nativescript.TNSRefMaziApp"
	},
	"dependencies": {
		"@angular/animations": "~5.2.0",
		"@angular/common": "~5.2.0",
		"@angular/compiler": "~5.2.0",
		"@angular/core": "~5.2.0",
		"@angular/forms": "~5.2.0",
		"@angular/http": "~5.2.0",
		"@angular/platform-browser": "~5.2.0",
		"@angular/platform-browser-dynamic": "~5.2.0",
		"@angular/router": "~5.2.0",
		"nativescript-angular": "~5.3.0",
		"nativescript-theme-core": "~1.0.4",
		"reflect-metadata": "~0.1.8",
		"rxjs": "~5.5.2",
		"tns-core-modules": "^4.2.0-2018-05-30-01",
		"zone.js": "~0.8.2"
	},
	"devDependencies": {
		"nativescript-dev-typescript": "~0.7.0",
		"typescript": "~2.7.2"
	}
}

My tns version installed is 4.0.2
My angular version is (ng --version)

Angular CLI: 6.0.3
Node: 10.2.1
OS: linux x64
Angular: 5.2.11
... animations, common, compiler, core, forms, http
... platform-browser, platform-browser-dynamic, router

Package                      Version
------------------------------------------------------
@angular-devkit/architect    0.6.3 (cli-only)
@angular-devkit/core         0.6.3 (cli-only)
@angular-devkit/schematics   0.6.3 (cli-only)
@schematics/angular          0.6.3 (cli-only)
@schematics/update           0.6.3 (cli-only)
rxjs                         5.5.11
typescript                   2.7.2

The questions

  1. Are the warnings something that i should ignore?
  2. If no what should i do?

Thank you
Thomas