Npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents


#1

These below warnings encountered while playing with Nativescript Cli versions/updations.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\nativescript\node_modules\fsevents)
:
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","ar
ch":"any"} (current: {"os":"win32","arch":"x64"})

These will cause any problems! Why these warnings are occurred?


#2

The lack of fsevents on a windows/linux OS is not supposed to cause any problems. The package is only needed, and used when the CLI is used under MAC OS.

The warning itself is issued by npm, informing you that certain packages incompatible to your system have been ignored.