No apk found after upgrade from 3.3.0 to 3.4.0


#1

i just update nativescript-cli and my project

from 3.3.0 to 3.4.3.

after upgrade, cli doesn’t work at all.

when i call ‘tns run android’ build ends up successfully but, at last, apk wasn’t generated and get an error

deleting node_modules, platforms wasn’t helped…

what did i wrong…?


#2

try
tns build android
and your apk shoud be in
/platforms/android/build/outputs/


#3

here’s my package.json

“dependencies”: {
@angular/animations”: “~5.2.0”,
@angular/common”: “~5.2.0”,
@angular/compiler”: “~5.2.0”,
@angular/core”: “~5.2.0”,
@angular/forms”: “~5.2.0”,
@angular/http”: “~5.2.0”,
@angular/platform-browser”: “~5.2.0”,
@angular/platform-browser-dynamic”: “~5.2.0”,
@angular/router”: “~5.2.0”,
@types/js-base64”: “^2.1.5”,
“buffer”: “^5.0.8”,
“crypto-js”: “^3.1.9-1”,
“i18n-iso-countries”: “^3.2.1”,
“js-base64”: “^2.3.2”,
“jshashes”: “^1.0.7”,
“lodash”: “^4.17.4”,
“moment”: “^2.19.1”,
“nativescript-angular”: “^5.2.0”,
“nativescript-antivirus”: “file:plugins/qs-antivirus/src”,
“nativescript-camera”: “3.0.2”,
“nativescript-drop-down”: “^3.1.3”,
“nativescript-iqkeyboardmanager”: “file:plugins\nativescript-iqkeyboardmanager”,
“nativescript-loading-indicator”: “file:plugins/nativescript-loading-indicator”,
“nativescript-localize”: “file:plugins/nativescript-localize”,
“nativescript-modal-datetimepicker”: “^1.0.3”,
“nativescript-ng-gradient”: “file:plugins/nativescript-ng-gradient”,
“nativescript-pro-ui”: “^3.2.0”,
“nativescript-root-check”: “file:plugins/qs-root-checker/src”,
“nativescript-secure-storage”: “^2.2.1”,
“nativescript-theme-core”: “1.0.4”,
“reflect-metadata”: “0.1.10”,
“rxjs”: “^5.5.0”,
“tns-core-modules”: “^3.4.1”,
“zone.js”: “^0.8.4”
},
“devDependencies”: {
@angular/compiler-cli”: “~5.2.0”,
@ngtools/webpack”: “~1.8.2”,
“ajv”: “^5.2.2”,
“babel-traverse”: “6.4.5”,
“babel-types”: “6.4.5”,
“babylon”: “6.4.5”,
“codelyzer”: “^4.2.0”,
“copy-webpack-plugin”: “~4.0.1”,
“css-loader”: “~0.28.7”,
“extract-text-webpack-plugin”: “~3.0.0”,
“lazy”: “1.0.11”,
“nativescript-css-loader”: “~0.26.1”,
“nativescript-dev-sass”: “^1.3.2”,
“nativescript-dev-typescript”: “^0.6.0”,
“nativescript-dev-webpack”: “^0.9.0”,
“nativescript-worker-loader”: “~0.8.1”,
“node-sass”: “^4.5.3”,
“raw-loader”: “~0.5.1”,
“resolve-url-loader”: “~2.1.0”,
“sass-loader”: “~6.0.6”,
“tns-platform-declarations”: “~3.3.0”,
“tslint”: “5.6.0”,
“typescript”: “2.6.2”,
“uglifyjs-webpack-plugin”: “~1.1.6”,
“webpack”: “~3.8.1”,
“webpack-bundle-analyzer”: “^2.8.2”,
“webpack-obfuscator”: “~0.11.2”,
“webpack-sources”: “~1.0.1”
}


#4

Hi marko89,

tried, not thing’s in there. :frowning:

app/build/outputs/apk also empty


#5

@jaykim what version is the android runtime? What’s the specific version of your nativescript CLI? What is the complete build output?