New plugin deps aren't pulled down by Sidekick


#1

After adding a new plugin to my project, sidekick wouldn’t download the new dependency using the build or run options. The app would run, but anytime I tried to hit code that used the plugin, the required native code wasn’t found. It wasn’t until I ran tns run ios/android that the dependencies were actually pulled down. Is there a way to make that work from within sidekick, or do I just need to build from the CLI whenever I add a plugin?


#2

Hey @freshlytyped,

Sorry for the late reply here. So this should work. Under the hood Sidekick uses tns run to actually build and deploy apps locally. (For cloud builds Sidekick obviously can’t use your local CLI install, but cloud builds should still automatically pick up dependency updates like this.)

If you’re still having this problem we’d appreciate it if you could create an issue on https://github.com/NativeScript/sidekick-feedback/issues with details about the OS you’re using, the Sidekick version you’re using, as well as the plugin you’re trying to update. Hopefully we can isolate the problem and fix this up.

Thanks!