Nativescript Sidekick needs CLI even though its installed


#1

I downloaded the Nativescript Sidekick Application for Windows. When i run it, it says Nativescript CLI 4.1.0+ is required to run.

When i press install i get Error: “TNS Doctor does not detect the version of NS CLI”

But i downloaded CLI many times its even listed as my npm package.

Capture3

What can be the problem? I ran the cmd as admin when i downloaded nativescript. I downloaded it globally. I cant think of anything else to do? Let me know if you need any more information.


#2

From your bash (I am not sure if Windows cmd can access node packages, since I do not develop in Windows platform) check typing tns --version or any other NativeScript command to check if nativescript-cli is working. And also do not forget to check your Environment Variables.


#3

I have the same issue. I just installed the NS CLI version 4.1.2, node 8.11.3 and tried to install Sidekick but it always tells me there is no CLI installed. If I run any tns command in the windows command prompt it works. I have not installed Java as I want to compile in the cloud. Still “tns info” shows me “Component nativescript has 4.1.2 version and is up to date”. Any help would be greatly appreciated. I try to run this on Windows 10.

Greetings,

Bernd


#4

Yeah its so weird cuz Tns command works in my command prompt but ill run like Git Bash and it will say tns is not recognized. Have no idea maybe environment variables? I checked it out but im not sure what it should be like


#5

Well, I installed it in a local VM and I guess a reboot of the VM did the trick… So my guess is that there was a problem with the environment variables.