NativeScript Sidekick hangs


#1

Hi,

I tried the newest version of NativeScript Sidekick: It has been installed with root:root inside the /opt directory. The sh file was executable for anyone and I was able to start it, but it hangs on startup. There seem to be missing rights on some used files.

When I start it with sudo, it successfully starts, but it hangs few minutes later - probably because the sudo session timeouts. And I don’t like to start it with the root user…

My installation:

$ cat /etc/environment
[…]
JAVA_HOME="/usr/lib/jvm/java-8-openjdk-amd64"
ANDROID_HOME="/home/martin/Programme/android/sdk"

~$ cat .profile
[…]
export ANDROID_HOME="/home/martin/Programme/android/sdk"

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash - sudo apt-get install -y nodejs
sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0:i386 libstdc++6:i386 sudo ANDROID_HOME/tools/bin/sdkmanager "tools" "platform-tools" "platforms;android-25" "build-tools;25.0.2" "extras;android;m2repository" "extras;google;m2repository" sudo apt install npm
sudo npm install nativescript -g --unsafe-perm sudo apt-get install -f ‘/home/martin/Downloads/NativeScript/NativeScriptSidekick-amd64.deb’

The last command was successful, but produced the following message:

N: Can’t drop privileges for downloading as file ‘/home/martin/Downloads/NativeScript/NativeScriptSidekick-amd64.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Keine Berechtigung)

Best regards
Martin


#2

Sounds like a bug with Sidekick - can you report this directly to the team here on Github? https://github.com/NativeScript/sidekick-feedback/issues


#3

Curiously it works without sudo now, maybe because of my system restart, any I can’t reproduce it anymore. Should I report it anyway?


#4

Interesting. Yeah it can’t hurt to report the problem, but glad to hear you got it working!


#5

Hmm I don’t have enough info for a ticket. Unfortunately I purged sidekick which probably deleted the logs… sorry! Next time I’ll know to keep them. I also tried to setup everything from the start again, but I didn’t get the problem anymore.