Nativescript-exoplayer


#1

Hi All,
My exoplayer is not working .
https://www.npmjs.com/package/nativescript-exoplayer.
If anyone have worked on it and is working fine , pls help me too
thamks


#2

Hey @mukku and welcome to the forums!

Please be more specific when requesting help, or asking questions. ‘X is not working’ is not very helpful. Consider specifying the platform [iOS/Android], version of the plugin, HOW you are using the plugin, WHAT the error is/ WHAT the behavior is?


#3

sorry for my mistakes,

my platform is ios
“nativescript-exoplayer”: “^3.3.2”,

i am working on angular + nativescrpt


#4

Is there code related to using the exoplayer?


#5

In html,

    <exoplayer *ngIf="!!signVideo" [width]='videoWidth' [height]='videoHeight' [src]="signVideo" controls="true"></exoplayer>

in component,

import {registerElement} from “nativescript-angular/element-registry”;
registerElement(“exoplayer”, () => require(“nativescript-exoplayer”).Video);


#6

Are you sure you are sending right video file, did you verify the path?


#7

yes


#8

As you are using a remote video, did you test whether a local video or the default remote video shown in example works?


#9

i am trying to play a video which was recorded in the app itself.

i also tried with local video , but that too didnt work


#10

Your logs look like you are using remote video. Can you try uploading a sample project where we can see the issue?


#11

i have done a sample project


#12

You are using an invalid path, it supposed to be ~/video/abc.mp4

Note: Please try to be more specific when you face any issues, try to share the code snippet and more importantly don’t paste logs as screenshot, make it as text.