Nativescript CLI android emulator return error

android

#1

hello everyone
i’m reading the nativescript book of Mike and Nick Branstein
i followed all steps to set up and configure the nativescript CLI and everything worked fine
but…when i tried to run the helloworld app created, using the emulator i got the below error

image

i don’t know if the error is due because i’m running nativescript CLI in a vm using vmware workstation. the problem seems to be the emulator

thank you
G.


#2

Try starting the emulator from Android Studio using AVD Manager.


#3

thank you manojdcoder, but i don’t have android studio. the installation script just downloaded the android sdk and android tool. i don’t have the android studio
did i miss something? i just followed and lunched the script as described in the guide

G


#4

Could you please point which installation script you used?


#5

i used this script

@powershell -NoProfile -ExecutionPolicy Bypass -Command "iex ((new-object net.webclient).DownloadString('https://www.nativescript.org/setup/win'))"

that i found here

https://docs.nativescript.org/start/quick-setup

and was mentioned in the book

image


#6

Unfortunately I’m not a Windows user neither used that installation script. Google recently made Android Studio as mandatory one for handling Android SDK and Tools, so usually launching Emulator from Android Studio fixes this kind of issues.


#7

just for your info. i have installed android studio and i tried to run the emulator
i got an error related to the missing file


#8

May be emulator file is corrupted, try setting up a emulator from Studio.


#9

doesn’t work neither, i guess it is a conflict with the virtual machine


#10

issue fixed moving to a phisical machine. installing in a VM using vmware doesn’t work