Nativescript 4 project and plugins


#1

I tried to install nativescript-videoplayer which is listed as compatible for Nativescript 4.0 but I get this error message:

nativescript-videoplayer@4.0.3 requires a peer of tns-core-modules@^3.0.0 but none was installed.

Is there a way around this? I get it when I add this to my angular component.

registerElement(“VideoPlayer”, () => require().Video);


#2

I think you are getting this warning not error?

npm WARN nativescript-videoplayer@4.0.3 requires a peer of tns-core-modules@^3.0.0 but none is installed. You must install peer dependencies yourself