NativeScript 4 not working on CircleCI


#1

I have a simple CircleCI configuration which runs on a MacOS container that will checkout some test code, install NS dependencies as described in the docs and then builds the project for iOS.

This works perfectly when I use nativescript@3 but always fails when using nativescript@4 with the following error:

You are missing the nativescript-cloud extension and you will not be able to execute cloud builds. 
Your environment is not configured properly and you will not be able to execute local builds.

Any ideas what NS4 needs extra from NS3 ?

Versions:

$ node -v
v8.9.1

$ npm -v
5.5.1

$ xcodeproj --version
1.5.9

$ pod --version
1.5.3

# Command-line tools for Xcode
$ pkgutil --pkg-info=com.apple.pkg.CLTools_Executables
version: 9.1.0.0.1.1508540944

#2

The solution is to instal the six python package:

pip install six