LiveSync not working on Windows


#1

For the last couple of days, LiveSync has stopped working on my Windows 10 laptop. All was OK till then - I’d start the app (tns debug android) and, every time the code changed, the app would restart (I use Genymotion for the emulator). Now, nothing happens. Worse, I can’t kill the running app - Ctrl C makes no difference in the Powershell window. I’m forced to use Task Manager to kill the process and restart it from the command line every time I make a change to my code.
I’ve upgraded (from 3.1.1 to 3.1.2 - 3.1.3 upgrade fails), downgraded, replaced the runtime, reinstalled the tns modules - all to no avail.
I’ve looked on Google, found no reference to this kind of behaviour.
Anyone else seen this behaviour? Any ideas on what could be wrong? All inputs welcome!


#2

Weird thing to note: I have another NativeScript app that I’d built some time ago. LiveSync works perfectly in that case, when I run tns debug android in that app’s directory.

node and nativescript are installed globally, so there are no “local” issues with them in the app where LiveSync is not working. I’ve reinstalled the runtime, but that’s made no change. I blew away the node-modules subdirectory and did an npm install, then ran tns debug android again - still no LiveSync. What am I missing?


#3

Perhaps the typescript transpiler is not kicking in, and the CLI doesn’t pick up changes in the javascript files? Could you test something for me? Start tsc -w in the application directory, and tns run/debug android in a separate process, see if there will be any change in behavior.


#4

@Pete.K, just tried that - says tsc is not recognized as a command! I don’t use TypeScript, so I guess there’s no transpiler installed.