Legacy Swift Version when using ios pod


#1

Hey.
Im trying to get socketio library to work (be it either with plugin nativescript-socketio or nativescript-socket.io, either is fine) but im encountering Swift version problem:

“Use Legacy Swift Language Version” (SWIFT_VERSION) is required to be configured correctly for targets which use Swift. Use the [Edit > Convert > To Current Swift Syntax…] menu to choose a Swift version or use the Build Settings editor to configure the build setting directly.

Now I’ve searched and tried for quite a while with no success, I have previously developed android apps, not ios so Im kind of lost here.
I cant even get demo app to work with socketio. There isnt anywhere any easy guide on how to get plugins with weird swift versions to work, just many different approaches (which i tried and are not working).
Could someone tell me what are the steps to deal with this swift version error?

Im trying it on OS X El Capitan 10.11.6 and XCode 8.2.1
Do i need to update my software? Any help greatly appreciated.

Thanks


#2

@chizuke place this in the Podfile

post_install do |installer|
    installer.pods_project.targets.each do |target|
        target.build_configurations.each do |config|
            config.build_settings['SWIFT_VERSION'] = '3.0'
        end
    end
  end

#3

thank you for your answer, but should i place it in my projects podfile or the plugins that im trying to add?
and is there any way to make it automatic like a script or something, that adds it before build?


#4

you can add it inside the Podfile in your project, or in the plugin.
Adding it to the Podfile in your project is a better option, because that will be in your source control


#5

alrighty, thanks a lot