Keyboard overlapping textview


#1

how do i make my textview automatically move up when its clicked and Keyboard shows up! because mine
gets overlapped with the keyboard so that the textview is under keyboard!

<TextView hint="what's up with you" text="{{ctext}}" id="chat"    col="0" row="1" editable="true" class=" message red " colSpan="2" />

@jen.looper @nraboy


#2

For iOS, use this package: https://www.npmjs.com/package/nativescript-iqkeyboardmanager.


#3

I have a problem with the keyboard covering buttons of a dialog, is there away to solve this?


#4

With IQKeyboardManager (that Sean linked to) you can specify how much space there is between the keyboard and the input field. So if you have an input field with buttons below, and you want to keep those buttons visible while the keyboard is open, play with this property: https://github.com/tjvantoll/nativescript-IQKeyboardManager/blob/54bcec25fe7f09b6d2a4ea8428ac80fb3edb19cd/demo/app/main-view-model.ts#L47


#5

But am on Android! @eddy , and after navigating from mapbox page, the
keyboard works fine, hiding the taskbar as well as moving the textview up
so that its visible!


#6

Hey @Eddy
I have the same issue here…What is the right way to implement this solution on android…
The weird thing here is that when I first open the app the issue is happening but when I put the app on background and then return to it the issue is gone and everything works just awesome -> here is the example - Keyboard overlap the page view - nativescript bug


#7

For anyone who still have this, @erkanarslan found the thing the solve it.
Just add android:windowSoftInputMode="adjustResize" in the activity section on the AndroidManifest.xml file.

If you guys want to see the full issue is here - https://github.com/NativeScript/NativeScript/issues/5088


#9

Thanks to you guys ! I was facing the same problem in my project where i used the telerik-side-drawer template. But for it to work in my case, i had to use the proerty “adjustPan” instead of adjustResize which did’nt work !


#10

i did adjustResize ! and it works only when you tap the field that is just
showing behind the keyboard! and if two more are behind, it hard, Best
option is to put everythin in a schrollview!!


#11

Hi devyaz ! in my case, it didnt work (until i used the adjustPan or adjustResize property) even if i put all the form in a ScrollView. I think it might be related with the use of the telerik sideDarwer because i didnt face this problem in projects where i didnt use a sideDrawer.


#12

hii @marrabou ,i’m also having this problem and i’m also using telerik sideDrawer. how did you manage to solve the problem?


#13

hi @bhavincb, i fixed it by adding this property to the <activity> tag in AndroidManifest.xml :
android:windowSoftInputMode=“adjustPan” .
I think it is related with the usage of the telerik side drawer like i said upper.


#14

adjustResize didnt work for me too. Your solution adjustPan worked perfectly :smiley: Thank you @marrabou


#15

hii @marrabou,
don’t you think we should report this issue?


#16

You’re welcome @krisidmisso !
hi @bhavincb, i don’t know, i’m not very aware off the issue reporting process, i’ll look at it when i’ll have some time or may be you know how it’s done ?