Just splash screen after upgrade CLI


#1

Hi all, i am trying to starting with Nativescript, i have downloaded slideckic and started a new blank app, but at the moment i run the app from slideckic app, it just display the splash screen, i have updated the file and the webpack runs, but nothing happens.

Node Version: v10.7.0
NPM Version: 6.3.0
Nativescript CLI: 4.2
nativescript-theme-core: ~1.0.4
tns-core-modules: ~4.2.0
nativescript-dev-webpack: ^0.15.1
Angular Flavor
MacOs High Sierra


#2

Which flavour you are using for development?
What is your root view?


#3

Hi i am using mac OS High Sierra 10.13, the root view is Home, it is a fresh app created with slideckic


#4

By flavour I meant, it’s Core / Angular / Vue?
By root view I meant what is the component in the root view, is it a frame / view, what all it has?


#5

Sorry, i am just starting this journey Flavor is Angular and in the root view i have a view


#6

If you just have a View, it may be transparent and splash in the background may be visible. Try setting a background color to your view. Add a router and try to navigate.


#7

i have downgrade to version 4.1 and it works now, maybe is the configuration of my environment it is not ready for the 4.2 version, i am updating XCode, maybe that is the problem… i will notify again. Thanks manojdecoder


#8

I thought you were talking about Android. At least I never faced such issue with iOS, especially with 4.2.


#9

Finally upgrade to latest tns version, xcode latest, npm latest, and nothing, fresh tns create app, tns run ios --bundle, and it crash at start, never pass the splash screen, i want to test Nativescript but can’t success :frowning: