Is it safe to update NS packages ? How can I know


Currently my package.json file is :

	"devDependencies": {
		"babel-traverse": "6.4.5",
		"babel-types": "6.4.5",
		"babylon": "6.4.5",
		"lazy": "1.0.11",
		"nativescript-dev-android-snapshot": "^0.*.*",
		"nativescript-dev-typescript": "^0.4.0",
		"typescript": "~2.2.1"

But TS has 2.6 version nowdays.

  • How can I know if it is safe to update , same question for nativescript-dev-typescript .

  • What Is the difference ? and is it safe to update both ?


Angular 5 does not even support 2.6. The supported targets for that are >=2.4.0 | < 2.5.0. Many core dependencies will have peer dependency or dev dependency versions that will throw warnings when you run npm install if they are mismatched or not supported.

You can always refer to what tns create generates, as a good rule of thumb on what is production ready.