iOS free development account provisioning issues


#1

Hey guys, is anyone having issues recently with iOS provisioning? I have followed the guide here exactly but no joy. To go more into detail as to what I’ve tried to load my nativescript app (which was working up until a few days ago) I’ve tried the following:

  1. Remove all deveopment certificates from keychain
  2. Deleted all provisioning profiles witihn ~/Library/MobileDevice/Provisioning Profiles
  3. Created a project in xcode with the same bundle identifier as my NativeScript project
  4. Chose “Automatically manage signing” in the xcode project settings window and chose my name (personal team) as the team for the signing certificate.
  5. Ran a tns platform clean ios command to wipe existing files and rebuild
  6. Ensured that the newly created certificate was present in my keychain and trusted.

At this point when I run tns run ios I get a bunch of errors where fse.node and fsevents.o have conflicting code signing identities. Here is one of the error lines…

"Error Domain=IDEProvisioningErrorDomain Code=8 \"fsevents.o has conflicting provisioning settings.\" UserInfo={NSLocalizedDescription=fsevents.o has conflicting provisioning settings., NSLocalizedRecoverySuggestion=fsevents.o is automatically signed for distribution, but a conflicting code signing identity iPhone Developer has been manually specified. Remove the \"signingCertificate\" entry from your Export Options property list, or switch to manual signing by setting \"signingStyle\" to \"Manual.}",

So at this point I went through the NativeScript guide as previously mentioned where I used SideKick to generate a certificate and provision profile. This was fine, but it doesn’t seem to do anything with these files other than generate them - are you supposed to install the certificate? I went through the process of the above steps to clear all certificates and provisioning profiles and then installed the created certificate into keychain, but it also didn’t work. When I went back into XCode it looked as if it invalidated the certificate.

So yeah at a complete loss as to how to continue developing as I simply can’t run the app on my phone. Any help would be hugely appreciated!