Ios build failed with xcodebuild: error: invalid option '-quiet'



Trying to run the tutorial application on the IOS emulator:
tns run ios
Searching for devices…
Executing before-liveSync hook from /Users/fhilton/github/nativescript/HelloWorld/hooks/before-liveSync/nativescript-angular-sync.js
Skipping prepare.
Building project…
Xcode build…
xcodebuild: error: invalid option ‘-quiet’

I googled around and can’t find anyone else with the issue about an invalid option of quiet, thoughts?

tns run android worked great.


It looks like I might have an older version of xcode. Going to try upgrading.


My version of xcode was the issue. My mac did not show a need for any updates in the App Store, however I searched for and installed the latest xcode and now the build is working :slight_smile:



which version of Xcode are you using now ?
I’m on macOS 10.11 with Xcode 7.3.1 and I’m getting the same error since I upgraded to {N} 3.2.0.

Should Xcode 8 fix the issue ?


yes, I update Xcode from 7.3.1 to 8.2.1 on macOS 10.11 El Capitan. Now works! :wink:

Get it from:


I just upgraded the nativescript version from 3.1 to 3.4.3 and now I have to upgrade Xcode from 7.2.1
I’m running macOS 10.10.5 which was working fine with Xcode 7.2.1

I wonder why the latest nativescript requires a newer Xcode version. I’m trying to install Xcode 7.3.1 to see if that works. Otherwise I’ll have to upgrade the OS which is a pain.
Is there any information somewhere about the requirements for updating the nativescript version?

edit: it seems that Xcode 7.3.1 requires 10.11 as a minimum which it doesn’t tell you when trying to install it.