iOS app not installing


#1

I created the IPA file with an Ad Hoc/Distribution certificate, and the app was built successfully using the Sidekick cloud build service, but when I try install it on my iPhone 8 via Apple Configurator 2 (due to Apple’s ridiculous decision to remove app management from iTunes) I see the app appear on the phone’s screen but the icont is darkened, and when clicking on it I get an error saying that the app cannot be installed, please try again later. So the file is there on the device, mostly installs (up to about 75%) then goes dark and presents the error.

Does anyone have the same type of issue and have you any idea of what could be wrong? I’m not seeing any logs generated by Apple Configurator 2, so have no idea what the fault is or where installation is bombing out.

Please help!


#2

Are you sure the Device UDID is added to the provisional profile? Are you on Windows (since you mentioned it’s cloud build)?


#3

Is that necessary for an ad hoc cert? I can’t remember if I did that with my previous app. The cert is a production cert as far as I know, so that should work regardless, surely?


#4

If it’s a ad-hoc certificate and your account is not an enterprise one, yes you must add your device UUID to provisional before you generate a build.


#5

Ah ok cool, I completely forgot about that. Will try that. Do you know where I can get my UDID on iPhone 8? Sorry, I’m an amateur dev, still learning, especially on the iOS side. I’m using a Mac, so I assume I can use Apple Config 2 or iTunes to get the UDID of my device?

PS, Thanks for all your help thus far! :slight_smile:


#6

Ok, so that was definitedly the issue. Created a new provisioning profile and included the device, it worked, thanks!!

Problem now is: When trying to log in via the app, I’m getting the following error: The resource could not be loaded because the App Transport Security policy requires the use of a secure connection. What on earth do I do now?


#7

I believe the actual issue you created this post for, is solved. If you just put the same words in Google about Transport Security you will get the answer, it is something to add a key in info plist that enables non secure network requests inside your app.


#8

Yes, you are right, the post is solved, absolutely.

Was just asking due to the fact that I’m not really well versed in any of this. But will do the Google thing and continue. One last (hopefully kind of related) question: Where is the info.plist file on a Nativescript app?


#9

I mentioned so we don’t mix up multiple stuffs under one post.

Besides the documentation has everything you need, I would suggest to go step by step so you won’t miss anything you may suppose to know before hitting this stage. Still to answer your question, info plist or android manifest can be found inside ./app/App_Resources


#10

Thanks so much, you’ve been awesome! I came right. Am busy editing the file now :slight_smile:
Cheers!