Installation is not work properly


#1

when i install th native script library using
npm install –g nativescript , it gives some warning and after get installed … when open the terminal it fadeout ,ie comes and disabled

error

Support for Node.js 9.2.0 is not verified. This CLI might not install or run properly.

WARNING: adb from the Android SDK is not installed or is not configured properly.
For Android-related operations, the NativeScript CLI will use a built-in version of adb.
To avoid possible issues with the native Android emulator, Genymotion or connected
Android devices, verify that you have installed the latest Android SDK and
its dependencies as described in http://developer.android.com/sdk/index.html#Requirements

TIP: To avoid setting up the necessary environment variables, you can use the chocolatey package manager to install the Android SDK and its dependencies.


#2

First don’t use Node.js 9.2.0 since its not fully yet compatible, uninstall it and instead install LTS node which is Node v8.9.x

Second install Android Studio and then make sure you setup ANDROID_HOME and ANDROID_SDK_ROOT environment variables correctly based on your OS (google how to set them up its not hard)

Third: first uninstall nativescript using npm uninstall -g nativescript then install it using npm install -g nativescript


#3

thank you for your replay…i check is it okey


#4

i go through the steps but i face the same problem ie,when open tns terminal it displays and fade

WARNING: adb from the Android SDK is not installed or is not configured properly.
The ANDROID_HOME environment variable is not set or it points to a non-existent directory. You will not be able to perform any build-related operations for Android.
Error executing command ‘javac’. Make sure you have installed The Java Development Kit (JDK) and set JAVA_HOME environment variable.

There seem to be issues with your configuration.
? Do you want to visit the official documentation? No
? Do you want to run the setup script? No
Your components are up-to-date:
nativescript,tns-core-modules,tns-android,tns-ios

Autocompletion is already enabled

Installation successful. You are good to go. Connect with us on http://twitter.com/NativeScript.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules\nativescript\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

  • nativescript@3.3.1
    added 684 packages and updated 8 packages in 127.887s

i use ‘set ANDROID_SDK_ROOT=E:\Android\sdk’ for setting enviornment variable


#5

C’mon bud, if you read the logs you just shared you will know what to do; the are clear as a sky in summer day :stuck_out_tongue:
EDIT FOLLOW STEP 4 and 5 in this detailed guide , and you should be able to setup your environment variables correctly


#6

not able to install jdk


#7

If you need help you need to elaborate more than just saying this

What problems you faced installing and setting up jdk?

here is a video step by step installing JDK


#8

I put this step by step guide, give it a shot Installing Nativescript on Windows - Guide


#9

i am not getting
same error after changing the enviornment variable
Android coder not get tools->android manager


#10

Hi,now java_home path is okey
but i cannot find my Sdk folder after installing Android studio …i go through many links …search on appdata…but i cannot see…how to get it ?


#11

look at this link there is a video shows you how to setup the path Installing Nativescript on Windows - Guide


#12

NOTE: You can develop for iOS only on Mac OS X systems.
To be able to work with iOS devices and projects, you need Mac OS X Mavericks or later.

You need to have the Android SDK Build-tools installed on your system. You can install any version in the following range: ‘>=23 <=26’.
Run $ %ANDROID_HOME%\tools\android from your command-line to install required Android Build Tools.

There seem to be issues with your configuration.
? Do you want to visit the official documentation? No
? Do you want to run the setup script? No
Your components are up-to-date:
nativescript,tns-core-modules,tns-android,tns-ios

When you file an issue, these warnings will help the NativeScript team to investigate, identify, and resolve the report.
Please, ignore them if you are not experiencing any issues with NativeScript.

how to ignore this issue ?


#13

Please don’t be lazy google your issues first for solution before posting here, this way you save your time and others time. All the issues you posted here are generic and related to java and android studio not even Nativescript.

Anyway, here is a quick video how to install SDK IN ANDROID STUDIO


#14

Thank you ,
But i already solved the issue…after restarting it will works…
thanks for helping me


#15

good to hear :slight_smile: and welcome to the world of Awesome NativeScript