I can not update the CLI


#1

I have tried to uninstall and reinstall nativescript and I have tried to simply update it. My current installed version is 3.4.0, but tns doctor tells me that the latest version is 3.4.3. I can not open Nativescript Sidekick because it tells me that it needs the latest version of Nativescript CLI (3.4.3) installed.

Is anyone else seeing this issue or have any suggestions as to what I may be doing wrong?


#2

Do npm clean cache --force it will say I hope you know what you are doing but ignore it then it will install new version


#3

This doesn’t seem to make a difference… Whenever I run the command to uninstall nativescript, I can still run the tns --version command and get a response. This should not be the case, correct?

Is there a particular directory I should be in whenever these commands are executed? I’m not sure what it is I’m doing wrong…


#4
I had the same issue three days ago but  I did ` npm cache clean –force` then `npm i -g nativescript` all good now!

#5

I usually add the specific version I want: npm i -g nativescript@3.4.3


#6

I tried those two things… Still haven’t figured out the issue.

I completely removed node and npm and all thing associated with them and reinstalled. Then I reinstalled nativescript and still the version showing up is 3.4.0…


#7

I think I figured something out, I just don’t know what to do about it… I believe that maybe nativescript is installed somewhere other than the npm folder… I say this because I can uninstall Nativescript with the npm commands and the nativescirpt folder disappears from within the npm folder. However, it is definitely still installed somewhere, somehow… I can run tns doctor and get the current version. Is there a way for me to check where else it’s installed? And/Or a way for me to uninstall it other than using the npm command?


#8

Sounds like you’re not using the -g option when installing from npm? :thinking:


#9

yeah, it sounds like nativescript is locally installed in the project folder where you are running tns info or tns doctor


#10

I’m using the -g option for sure…
And I’m not even in a project folder… :sob::sob:


#11

I just finally figured out the issue…

For one… the CLI was installed in another place… So I used where tns to find it and I removed all of its components.

Secondly, when I reinstalled it, it was telling me that tns was not a recognized command and so I had to go in and add the path to the npm folder to the PATH variable in enviornment variables for my user login…

I have no clue how all of that got so messed up, but it’s working now thank goodness.