High Sierra 10.13.3 and NS issue


#1

Hi,
After updating OSX to version 10.13.3 (or switching into newest 3.4 version of nativescript ) i’m seeing strange issue. before updating OSX and nativescript all was very fine, but now i see this issue:

CONSOLE ERROR file:///app/tns_modules/tns-core-modules/trace/trace.js:165:30: Error: Css styling failed: Error: undefined:1:16: missing '{'
CONSOLE ERROR file:///app/tns_modules/tns-core-modules/trace/trace.js:165:30: Error: Css styling failed: Error: undefined:1:16: missing '{'

This is happening if i’ll start new project with Geoceries templates, as soon as i will add ios platform and run emulator, OR just after i’ll add any css file to empty project.

So, i’ve setup new project and added folder ‘login’ with login.xml inside. ALl fine, but when i’ll added login.css into this folder, error arises.

Thank you for any help.

Edit: i’ve removed contents of bundle-config.js containing -

if (global.TNS_WEBPACK) {
    // registers tns-core-modules UI framework modules
    require("bundle-entry-points");

    // register application modules
    // This will register each `page` postfixed xml, css, js, ts, scss etc. in the app/ folder
    const context = require.context("~/", true, /(page|fragment)\.(xml|css|js|ts|scss|less|sass)$/);
    global.registerWebpackModules(context);
}

and removed login.css, next i’ve added login.css again - error was shown, and then i’ve restored contents of bundle-config again, and i’m able to edit login.css without issues now - no errors. Very strange ?


#2

I’ve encountered this issue also although i can’t find the bundle-config.js file within the file structure of the project.


#3

You can find this here : (i have {N} ver 3.4)
image

PS: i’ve installed Sass module , this partially removed this issue.
Not sure why, but after tns install sass - problem has gone. Since this install, i saw our error only once.

BTW i strongly suggest to use Sass from project start, it’s very helpfull.

PS2: In fact i think this issue arises when you’ll add new directory, with xml and css - and when css if empty this errer arises, the same is for empty xml file - i’m having errors untill ill add something to xml / css.


#4

In my case any empty css (scss) file is causing this.


#5

after upgrade tns-core-modules to ~4.0.0 this error no longer show


#6

In case anybody is reading, use the command npm i tns-core-modules@latest for force to install version 4.0.1 otherwise it install only 3.4.x