Failed to run my application with the emulator


#1

Hi,
this is my first topic in the NativeScript Forum!

In fact, I tried to run my first nativescript app with the Android emulator using this command “tns run android --emulator --timeout 300”, unfortunately, I got this error:

Cannot find connected devices.
Emulator start failed with: Cannot run your app in the native emulator. Increase the timeout of the operation with the --timeout option or try to restart your adb server with ‘adb kill-server’ command. Alternatively, run the Android Virtual Device manager and increase the allocated RAM for the virtual device.
To list currently connected devices and verify that the specified identifier exists, run ‘tns device’.
To list available emulator images, run 'tns device --available-device

By the way, I could launch my Android emulator using the AVD Manager and it’s working :frowning:
And even when I start the emulator and I run the NativeScript command , I got the same error message!!

Thanks for helping in advance.


#2

I’m not sure why you have this problem, but you can try to run your app on Genymotion emulator.
By my opinion it’s better then the original one.


#3

Like @bozhirarc said,
you should really try Genymotion emulator.

Also, after launching your virtual device, try running tns devices to see if nativescript is able to detect your device.
also run adb devices that should also list your virtual device. If you can see your device in these places, then it should launch fine.