Failed to apply plugin [id 'com.google.gms.google-services'] for input string + in nativescript


#1

Hello,
I am creating an application in Nativescript2 with angular2.
I am using following plugins(Pakage.json) in my application and now im getting below error.

A problem occurred evaluating script.

Failed to apply plugin [id ‘com.google.gms.google-services’]
For input string: “+”

Can anyone please help me to resolve this.

following is content of my build.gradle

buildscript {

repositories {
    google()
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.3.3'
           classpath "com.google.gms:google-services:3.1.1"

}

}

allprojects {
repositories {
google()
jcenter()
}
}

task clean(type: Delete) {
delete rootProject.buildDir
}

Content from app.gradle:

android {
defaultConfig {
generatedDensities = []
applicationId = “org.nativescript.LiveTrac”
}
aaptOptions {
additionalParameters “–no-version-vectors”
}

project.ext {
  googlePlayServicesVersion = "+"
}

}

package.json(Plugins used)

"dependencies": {
	"@angular/animations": "~5.2.0",
	"@angular/common": "~5.2.0",
	"@angular/compiler": "~5.2.0",
	"@angular/core": "~5.2.0",
	"@angular/forms": "~5.2.0",
	"@angular/http": "~5.2.0",
	"@angular/platform-browser": "~5.2.0",
	"@angular/platform-browser-dynamic": "~5.2.0",
	"@angular/router": "~5.2.0",
	"base-64": "0.1.0",
	"cache": "2.1.0",
	"guid": "0.0.12",
	"nativescript-angular": "~5.2.0",
	"nativescript-cache": "1.0.0",
	"nativescript-checkbox": "3.0.3",
	"nativescript-email": "1.5.1",
	"nativescript-exit": "1.0.1",
	"nativescript-geolocation": "4.2.2",
	"nativescript-google-maps-sdk": "2.5.0",
	"nativescript-openurl": "1.0.2",
	"nativescript-phone": "1.3.1",
	"nativescript-plugin-firebase": "5.1.7",
	"nativescript-snackbar": "2.0.1",
	"nativescript-social-share": "1.5.0",
	"nativescript-telerik-ui": "3.1.4",
	"nativescript-textinputlayout": "2.0.2",
	"nativescript-theme-core": "~1.0.4",
	"reflect-metadata": "~0.1.8",
	"rxjs": "~5.5.2",
	"tns-core-modules": "~3.4.0",
	"utf8": "3.0.0",
	"zone.js": "~0.8.2"
},