Error when using tns publish ios --ipa, 'there must be at least one .app file.'


#1

I’m getting the following error when using ‘tns publish ios --ipa path-to-ipa’:
In the .ipa the ITMSTransporter is uploading there must be at least one .app file.

A .app does exist in the same directory as the .ipa so I’m guessing that this is the result of something else.

Anyone have any insight into what may be causing this?


#2

Did you find the reason for this?


#3

I wasn’t able to find the cause, I ended up publishing and uploading via Xcode.

I suspect the issue is because of a bad npm package version combination but I wasn’t able to find the right combination.